As I write this on 7 May 2020, Wordfence estimates that over a million WordPress sites are at risk of having malware planted due to a combination of bugs in Elementor Pro (Pro only – doesn't affect free version) and Ultimate Addons for Elementor.

If you use either of these plugins, and especially if you use both, update now! The security flaws in question have been fixed in Elementor Pro version 2.9.4 and Ultimate Addons for Elementor version 1.24.2.

If you're interested in the details, check out Wordfence's security alert at https://www.wordfence.com/blog/2020/05/combined-attack-on-elementor-pro-and-ultimate-addons-for-elementor-puts-1-million-sites-at-risk/.

Stay in the loop!

Enter your email below to receive news, updates, and special offers.

Close